Which statement is true about a pre-authenticated request in Oracle Cloud Infrastructure Object Storage?
Correct Answer: D
Explanation https://docs.cloud.oracle.com/iaas/Content/Object/Tasks/usingpreauthenticatedrequests.htm You can create an unlimited number of pre-authenticated requests. You can't edit a pre-authenticated request. If you want to change user access options in response to changing requirements, you must create a new preauthenticated request. URL: https://docs.cloud.oracle.com/iaas/Content/Object/Tasks/managingbuckets.htm You can change a bucket's access from public to private or from private to public. Changing the type of access doesn't affect existing pre-authenticated requests. Existing pre-authenticated requestsstill work.
Question 22
Which service would you use if your big data workload required shared access and NFS-based connectivity?
Correct Answer: B
Question 23
Which two statements are true about Autonomous Data Warehouse (ADW) backup?
Correct Answer: A,B
Explanation Autonomous Database automatically backs up your database for you.In addition to automatic backups Autonomous Database also allows you take manual backups to your Oracle Cloud Infrastructure Object Storage. for example if you want to take a backup before amajor change to make restore and recovery faster. Also, Manual backups are only supported with buckets created in the standard storage tier if you provision an Autonomous Data Warehouse instance named ADWC1, the bucket name should be backup_adwc1 (the bucket name is lowercase)
Question 24
You are running a mission-critical database application in Oracle Cloud Infrastructure (OCI). You take regular backups of your DB system to OCI object storage. Recently, you notice a failed database backup status in the console. What step can you take to determine the cause of the backup failure?
Correct Answer: A
Explanation Database backups can fail for various reasons. Typically, a backup fails because either the database host cannot access the object store, or there are problems on the host or with the database configuration. First need to determining the Problem In the Console, afailed database backup either displays a status of Failed or hangs in the Backup in Progress or Creating state. If the error message does not contain enough information to point you to a solution, you can use the database CLI and log files to gather moredata. Then, refer to the applicable section in this topic for a solution. Database Service Agent Issues Your Oracle Cloud Infrastructure Database makes use of an agent framework to allow you to manage your database through the cloud platform. Occasionallyyou might need to restart the dcsagent program if it has the status of stop/waiting to resolve a backup failure. Object Store Connectivity Issues Backing up your database to Oracle Cloud Infrastructure Object Storage requires that the host can connect tothe applicable Swift endpoint. You can test this connectivity by using a Swift user. Host Issues One or more of the following conditions on the database host can cause backups to fail: - Interactive Commands in the Oracle Profile - The File System Is Full - Incorrect Version of the Oracle Database Cloud Backup Module - Changes to the Site Profile File (glogin.sql) Database Issues An improper database state or configuration can lead to failed backups. - Database Not Running During Backup - Archiving ModeSet to NOARCHIVELOG (When you provision a new database, the archiving mode is set to ARCHIVELOG by default. This is the required archiving mode for backup operations) - Stuck Database Archiver Process and Backup Failures - Temporary Tablespace Errors - RMAN Configuration and Backup Failures - RMAN Retention Policy and Backup Failures - Loss of Objectstore Wallet File and Backup Failures TDE Wallet and Backup Failures - Incorrect TDE Wallet Location Specification - Incorrect State of the TDE Wallet -Incorrect Configuration Related to the TDE Wallet - Missing TDE Wallet File As this is not new provisioned database and already in the ARCHIVELOG , regular backups of DB system to OCI object storage in places, so the best answers are, - Ensure that your database host can connect to the OCI object storage - Restart the database service agent
Question 25
What is a "transferpackage" when transferring data to OCI via the OCI Data Transfer Service?